Welcome

Welcome to FortKnox Personal Firewall 2007

Personal Firewall

System Requirements

To install and run FortKnox Personal Firewall, you'll need the following minimum requirements:

  • 300 MHz processor or better
  • 64 MB of RAM available
  • 200 MB of free hard disk space
  • some other firewalls products and products that use low level drivers to filter network communication may produce incompatibility. It is recommended that you have installed only one firewall product on your system. For list of known incompatible products please visit www.fortknox-firewall.com/incompatibility.txt

FortKnox Personal Firewall will operate on the following versions of Microsoft Windows:

  • Windows 2000 (32-bit)

  • Windows XP (32-bit)

  • Windows Vista (64-bit and 32-bit)

Copyright © NETGATE Technologies s.r.o., 2007. All Rights Reserved.


Statistics

The Network traffic and attack history window shows graphs for incoming and outgoing data and graph of attacks happened in last time period.


Connections

The Active network connections window lists all inbound and outbound connections that are or have been established on your system. To learn more about individual connection click on selected connection or press the 'Details' button. To terminate a process that established the connection press the 'Terminate' button. To backtrace a route to the remote address select 'Trace route' button. To lookup address in the WHOIS database select 'WhoIs Lookup' button.


Advanced

The Advanced firewall rules window lists all advanced rules that are active on your system. Advanced rules has higher priority than application rules. To add a new rule press the 'Add rule' button. To edit a rule select the 'Edit rule' button. To remove a rule press the 'Remove' button.

Advanced Rules dialog allows you to specify extended firewall rules. These rules have more priority than application rules. 'Description' field could be any text to identify the rule. 'Protocol' is the type of protocol that is used to communicate between two computers, use 'Any' protocol to match all protocols. 'Route' could be incoming and outgoing, use 'Any' to match both directions. 'Process' field could be empty to match all applications or use '...' button to limit rule to a specific application only. To limit rule to a specific time period or specific user, use 'User' and 'Temporary restriction' lists. 'Local host' is IP address of your computer. Your computer can have more than one network card. Use 'All addresses' option to match all your network interfaces or you can specify individual network card/address by entering MAC address or IP address. When entering IP address you have the option to specify 'Port' and 'Subnet Mask'. 'Remote host' is the IP or MAC address of the remote computer. Address 0.0.0.0 with mask 'Any' means any IP address.


Options

The Options window contains all settings of FortKnox Personal Firewall. The 'General' tab allows you to set common firewall settings. When 'Disable sharing of my files and printers' option is active all access to your files and printers is blocked. Active 'Disable network neighborhood browsing' option disables browsing of shared resources of the network computers. The 'Set Password' button allows you to protect firewall settings from being changed by setting access password. To show the security/blocked applications notification, check the 'Show security/blocked applications notification messages in the system tray' option. To not start firewall at system startup uncheck the 'Automatically load firewall at Windows startup' option. To change language and skins settings that match your individual preference set 'Active language' and 'Active skin' lists. To apply all changed settings on the 'General' tab, press the 'Apply' button. The 'Enhancements' tab allows you to set extended firewall settings. The Intrusion Prevention System (IPS) is integrated Intrusion Detection System (IDS) which detects known threats in the packet stream and actively response to them. When a threat is detected based on a signature, user is automatically notified about it and depending on default action, threat is blocked. 'Enable NETBIOS Protection' options automatically blocks all NETBIOS communication from computers located outside of local subnet range. 'Block Universal Plug and Play traffic' option blocks UPnP traffic which is often used for distributed denial of service attacks. You should disable this option if some of your application require the UPnP protocol to operate. 'Enable OS fingerprinting masquerading' option blocks common attackers methods to detect your operating system. 'Enable anti-MAC spoofing' option blocks all unexpected ARP traffic which was not requested by your system. MAC spoofing is a way to hijack a communication session between two computers in order to hack one of the machines. 'Enable anti-DNS spoofing' option blocks all unexpected DNS responses to your system to prevent DNS attacks. 'Enable anti-IP spoofing' option randomize sequence number for each communication packet to prevent hijacking of communication session with IP spoofing attack. 'Enable fingerprint authentication' option verify every application for file changes. To reset all fingerprints for all application use 'Reset fingerprints' button. With 'Automatically block attacker for:' option enabled, all attacks to your system are automatically blocked for specified time period. Enabled 'Block fragmented packets' option drops all fragmented IP packets. 'Enable portscan detection' option detects, notify and block scanning of your ports which is common hacker action to find out if have some ports open and usable for attacks. 'Enable DoS detection' option checks all traffic for known Denial of Service (DoS) attacks which overload system services and block usage of services by common users. 'Enable local network traffic' option allows traffic on local network subnet range. 'Enable time synchronisation' option allows traffic for time synchronisation over Internet servers. 'Enable DHCP' option allows the Dynamic Host Configuration Protocol traffic which can be used to automatically assign IP addresses and other TCP/IP configuration information. If you disable this option and you need DHCP for correct functionality of your system, you must create an advanced rule for UDP packets on remote ports 67 and 68. 'Enable DNS' option allows domain name resolution to IP addresses. If you disable this option, you must create an advanced rule that allows UDP traffic for remote port 53. To apply all changed settings on the 'Enhancements' tab, press the 'Apply' button. The 'Logging' tab allows you to set logs and e-mail notification settings. 'Enable Security log' option enables logging of important and security events. 'Enable System log' option enables logging of events related to firewall functionality. 'Enable Traffic log' option enables logging of all inbound and outbound network traffic. 'Enable Packet log' option enables logging of all communication packets including their data. To limit size of the traffic and the packet log use 'Maximum traffic log size' and 'Maximum packet log size' options. 'Delete old log files after' option sets number of days after which are the old log files deleted. Setting value to zero, turns this option off. 'Enable Notification' option turns on e-mail notification when security event occurs. To test your e-mail settings use the 'Test E-Mail' button. To apply all changed settings on the 'Logging' tab, press the 'Apply' button. The 'Miscellaneous' tab allows you to set ICMP and updates settings. On this tab you can set ICMP settings for incoming and outgoing packets. Change this settings only if you are experienced user. Enabled 'Notify me about newer version' option will notify you when a new version of FortKnox Personal Firewall is available. When 'Automatically update signatures' option is enabled, new signatures will be automatically downloaded and installed from the server. To update signatures manually, press the 'Update' button. To apply all changed settings on the 'Miscellaneous' tab, press the 'Apply' button.


Applications

The Individual application rules window lists all application specific rules. Every rule can have allow, deny or ask action set and every application connection that was confirmed by you is listed here. To select all items in the list press the 'Select All' button. To deselect all items in the list press the 'Deselect All' button. To change the action for selected rule use 'Allow', 'Deny' or 'Ask' buttons. Rules with action set to allow, permanently allow application to access the network. Rules with action set to deny, permanently deny application to access the network. For rules with action set to ask will the firewall show the confirmation dialog. The 'Remove' button deletes the rule from the list.


Traffic Log

The Traffic log window shows all inbound and outbound traffic that was realised for specified time period. To show the log from the different day select the popup calendar in the top right corner of the window. You have the option to switch between four different logs. The system log shows the firewall system activity. The security log show important or attack like activity. The traffic log shows all inbound and outbound connections made by applications. The packet log shows the traffic at packet level. To learn mode about individual log item press the 'Details' button. To clear active or old logs press the 'Delete' button. To backtrace the remote address select 'Trace route' button. To lookup the remote address in the WHOIS database press the 'WhoIs Lookup' button. To export traffic to a file select the 'Export...' button.


Buy

The Buy window shows information about FortKnox Personal Firewall purchase.


Support

The Support window allows you to contact technical support in case you need help with FortKnox Personal Firewall.


Statistics

Štatistiky

Okno História prenosov po sieti a útokov zobrazuje grafy pre prichádzajúce a odchádzajúce dáta a graf útokov, ktoré sa uskutočnili v poslednom časovom intervale.


Connections

Spojenia

Okno Aktívne sieťové spojenia zobrazuje všetky prichádzajúce a odchádzajúce spojenia, ktoré sú alebo boli uskutočnené na Vašom systéme. Ak sa chcete dozvedieť o individuálnom spojení viac, kliknite na zvolené spojenie alebo stlačte tlačidlo 'Detaily'. Ak chcete ukončiť proces, ktorý vytvoril spojenie, stlačte tlačidlo 'Ukončiť'. Na zistenie cesty smerom k vzdialenej adrese, zvoľte tlačidlo 'Trace route'. Ak si želáte vyhľadať adresu vo WHOIS databáze, zvoľte tlačidlo 'WhoIs Lookup'.


Advanced

Rozšírené

Okno Rozšírené pravidlá firewalu zobrazuje všetky pravidlá, ktoré sú aktívne vo Vašom systéme. Rozšírené pravidlá majú vyššiu prioritu ako pravidlá aplikácií. Ak chcete pridať nové pravidlo, zvoľte tlačidlo 'Pridať pravidlo'. Editovať pravidlo možno pomocou tlačidla 'Editovať pravidlo'. Ak chcete pravidlo odstrániť, zvoľte tlačidlo 'Odstrániť'.

Dialóg rozšírených pravidiel Vám umožňuje špecifikovať rozšírené pravidlá pre firewall. Tieto pravidlá majú vyššiu prioritu ako pravidlá aplikácií. Pole 'Popis' môže obsahovať akýkoľvek text na identifikáciu pravidla. 'Protokol' predstavuje typ protokolu, ktorý bude použitý na komunikáciu medzi dvoma počítačmi, zvoľte protokol 'Akýkoľvek', aby pravidlo vzťahovalo na všetky protokoly. 'Smer' môže byť prichádzajúci alebo odchádzajúci, zvoľte 'Akýkoľvek' aby sa pravidlo sa vzťahovalo na všetky smery. Pole 'Proces' môže
byť prázdne ak chcete aby sa vzťahovalo na všetky aplikácie alebo zvoľte tlačidlo '...' na obmedzenie pravidla na špecifické aplikácie. Na obmedzenie pravidla na špecifický časový interval alebo špecifického užívateľa, použite zoznamy 'Užívateľ' alebo 'Časové obmedzenie'. 'Lokálny počítač' je IP adresa Vášho počítača. Váš počítač môže mať viac ako jednu sieťovú kartu. Zvoľte možnosť 'Všetky adresy', aby sa pravidlo vzťahovalo na všetky Vaše sieťové zariadenia alebo môžete špecifikovať individuálnu sieťovú kartu/adresu zadaním MAC adresy alebo IP adresy. Pri zadávaní IP adresy máte možnosť špecifikovať 'Port' alebo možnosť zo zoznamu 'Maska'. 'Vzdialený počítač' predstavuje IP alebo MAC adresu vzdialeného počítača. Adresa 0.0.0.0 s maskou 'Akýkoľvek' znamená všetky IP adresy.


Options

Nastavenia

Okno Nastavenia obsahuje všetky nastavenia FortKnox Personal Firewall. Záložka 'Hlavné' umožňuje nastaviť bežné nastavenie firewalu. Ak je voľba 'Vypnúť zdieľanie súborov a tlačiarní' aktívna, všetok prístup k Vašim súborom a tlačiarňam je blokovaný. Aktívna voľba 'Vypnúť prechádzanie počítačov v sieti' zamedzí prechádzanie zdieľaných zdrojov počítačov v sieti. Tlačidlo 'Nastaviť heslo' Vám umožňuje chrániť nastavenia firewallu pred zmenou pomocou nastavenia prístupového hesla. Ak si prajete zobrazovať bezpečnostné správy/správy o blokovaných aplikáciách, zaškrtnite voľbu 'Zobraziť bezpečnostné správy/správy o blokovaných aplikáciách v systémovej lište'. Ak nechcete spustiť firewal po štarte systému, vypnite voľbu 'Automaticky spustiť firewall po štarte Windows'. Ak chcete zmeniť jazyk a skiny podľa Vašich individuálnych preferencií, nastavte zoznamy 'Aktívny jazyk' a 'Aktívny skin'. Ak chcete aplikovať všetky zmeny v záložke 'Hlavné', stlačte tlačidlo 'Použiť'. Záložka 'Rozšírené' umožňuje nastaviť rozšírené pravidlá firewallu. Intrusion Prevention Systém (IPS) je integrovaný Intrusion Detection Systém (IDS), ktorý zisťuje známe hrozby v paketovom toku a aktívne na ne reaguje. Keď je hrozba zistená na základe signatúry, užívateľ je automaticky upozornený a podľa nastavenia, hrozba je zablokovaná. Voľba 'Povoliť ochranu NETBIOS' automaticky blokuje všetku NETBIOS komunikáciu z počítačov, ktoré sa nachádzajú mimo rozsahu Vašej lokálnej podsiete. Voľba 'Blokovať UPnP prenos' blokuje UPnP prenos dát, ktorý je často využívaný na útoky na distribuované ochromenie služieb(DoS). Ak niektoré Vaše aplikácie vyžadujú UPnP protokol, mali by ste túto voľbu vypnúť. Voľba 'Povoliť maskovanie signatúry OS' blokuje bežné metódy útočníkov na zistenie Vášho operačného systému. Voľba 'Povoliť anti-MAC spoofing' blokuje všetok neočakávaný ARP prenos, ktorý nebol vyžiadaný Vaším systémom. MAC spoofing je spôsob ako sa napojiť na komunikačné spojenie medzi dvomi počítačmi s cieľom získať prístup k jednému z počítačov. Voľba 'Povoliť anti-DNS spoofing' blokuje všetky neočakávané DNS odpovede na Váš systém s cieľom predísť DNS útokom. Voľba 'Povoliť anti-IP spoofing' vytvára náhodné sekvenčné čísla pre každý komunikačný paket, aby sa predišlo napadnutiu komunikačného spojenia pomocou IP spoofing útoku. Voľba 'Povoliť identifikáciu podľa odtlačku' overuje každú aplikáciu na zmenu v jej súbore. Ak chcete resetovať všetky odtlačky pre všetky aplikácie použite tlačidlo 'Resetovať'. S aktívnou voľbou 'Automaticky blokovať útočníka na:', všetky útoky na Váš systém budú automaticky blokované po špecifikovanú dobu. Voľba 'Blokovať fragmentované pakety' blokuje všetky fragmentované IP pakety. Voľba 'Povoliť detekciu portscan' monitoruje, upozorňuje a blokuje skenovanie Vašich portov, čo je bežný postup útočníkov na určenie, či máte niektoré porty otvorené a vhodné pre útok. Voľba 'Povoliť detekciu DoS' kontroluje všetok prenos na Denial of Service (DoS) útoky, ktoré preťažujú systémové služby a blokujú využitie služieb ich bežnými používateľmi. Voľba 'Povoliť lokálny sieťový prenos' povoľuje prenos na lokálnej sieti. Voľba 'Povoliť časovú synchronizáciu' povoľuje prenos pre komunikáciu s internetovým serverom časovej synchronizácie. Voľba 'Povoliť DHCP' povoľuje prenos Dynamic Host Configuration Protokolu, ktorý býva využívaný pre automatické priraďovanie IP adries a iných informácií pre konfiguráciu TCP/IP. Ak vypnite túto voľbu a potrebujete DHCP pre správne fungovanie Vášho systému, musíte vytvoriť rozšírené pravidlo pre UDP pakety na vzdialených portoch 67 a 68. Voľba 'Povoliť DNS' povoľuje preklad názvov domén na IP adresy. Ak túto voľbu vypnete, musíte vytvoriť rozšírené pravidlo, ktoré povolí UDP prenos na vzdialený port 53. Ak chcete aplikovať všetky zmeny v záložke 'Rozšírené', stlačte tlačidlo 'Použiť'. Záložka 'Záznamy' umožňuje nastaviť vlastnosti záznamov a e-mailovej notifikácie. Voľba 'Povoliť bezpečnostné záznamy' umožňuje záznam dôležitých a bezpečnostných udalostí. Voľba 'Povoliť systémové záznamy' povoľuje záznam udalostí súvisiacich s funkčnosťou firewallu. Voľba 'Povoliť záznamy prenosov' povoľuje záznam všetkých prichádzajúcich a odchádzajúcich prenosov. Voľba 'Povoliť záznamy paketov' povoľuje záznam všetkých komunikačných paketov vrátane ich dát. Na obmedzenie veľkosti záznamov prenosov a paketov možno použiť voľby 'Maximálna veľkosť záznamu prenosov' a 'Maximálna veľkosť záznamu paketov'. Voľba 'Zmazať staré záznamy po' nastavuje počet dní po ktorom budú staré záznamy zmazané. Nastavenie tejto hodnoty na nulu toto nastavenie vypne. Voľba 'Povoliť notifikácie' zapne notifikáciu bezpečnostných udalostí e-mailom. Na otestovanie Vašich e-mailových nastavení zvoľte tlačidlo 'Otestovať e-mail'. Ak chcete aplikovať všetky zmeny v záložke 'Záznamy', stlačte tlačidlo 'Použiť'. Záložka 'Rozličné' umožňuje nastavenie ICMP a aktualizácií databázy. V tejto záložke môžete nastaviť nastavenia ICMP pre prichádzajúce a odchádzajúce pakety. Meniť tieto nastavenia je doporučené iba skúsenému užívateľovi. Povolená voľba 'Upozorňovať na novú verziu' Vám automaticky oznámi, keď bude k dispozícii nová verzia FortKnox Personal Firewallu. Ak je voľba 'Automatická aktualizácia signatúr' zapnutá, nové signatúry budú automaticky stiahnuté a nainštalované zo servera. Ak chcete signatúry aktualizovať manuálne, stlačte tlačidlo 'Aktualizovať'. Ak chcete aplikovať všetky zmeny v záložke 'Rozličné', stlačte tlačidlo 'Použiť'.


Applications

Aplikácie

Okno Individuálne pravidlá aplikácií zobrazuje všetky pravidla špecifické pre individuálne aplikácie. Každé pravidlo môže mať asociovaná akciu povoliť, zakázať a pýtať sa a je tu zobrazená každá aplikácia, ktorú ste potvrdili. Ak chcete označiť všetky položky v zozname, stlačte tlačidlo 'Označiť všetko'. Ak chcete odznačiť všetky položky v zozname, stlačte tlačidlo 'Odznačiť všetko'. Ak chcete zmeniť akciu pre zvolené pravidlo použite tlačidlá 'Povoliť', 'Zakázať' alebo 'Pýtať sa'. Pravidlá s akciou nastavenou na povoliť permanentne povoľujú aplikáciu prístup na sieť. Pravidlá s akciou nastavenou na zakázať sú permanentne zakázané pristupovať na sieť. Pre pravidlá, ktoré majú akciu nastavenú na pýtať sa, bude firewall zobrazovať potvrdzovací dialóg. Tlačidlo 'Zmazať' zmaže pravidlo zo zoznamu.


Traffic Log

Záznamy

Okno Záznamy zobrazuje všetky prichádzajúce a odchádzajúce prenosy, ktoré boli realizované za špecifikované časové obdobie. Ak chcete zobraziť záznam z iného dňa, zvoľte kalendár v pravej hornej časti okna. K dispozícii sú štyri rôzne druhy záznamov, ktoré možno zobraziť. Systémový záznam zobrazuje systémovú aktivitu firewallu. Bezpečnostný záznam zobrazuje dôležitú aktivitu a aktivitu útokov. Záznam prenosov zobrazuje všetky prichádzajúce a odchádzajúce spojenia uskutočnené aplikáciami. Záznam paketov zobrazuje prenosy na paketovej úrovni. Ak sa chcete dozvedieť viac o individuálnej záznamovej položke, stlačte tlačidlo 'Detaily'. Ak chcete Ak chcete vymazať aktívny alebo všetky záznamy, stlačte tlačidlo 'Zmazať'. Na zistenie cesty smerom k vzdialenej adrese, zvoľte tlačidlo 'Trace route'. Ak si želáte vyhľadať adresu vo WHOIS databáze, zvoľte tlačidlo 'WhoIs Lookup'. Ak chcete exportovať prenosy do súboru, zvoľte tlačidlo 'Export...'.


Buy

Kúpiť

Okno Kúpiť zobrazuje informácie o programe FortKnox Personal Firewall a možnosti jeho nákupu.


Support

Pomoc

Okno Pomoc umožňuje kontaktovať technickú pomoc v prípade keď potrebujete pomoc s programom FortKnox Personal Firewall.


Statistics

Statistiky

Okno Historie přenosů po síti a útoků zobrazuje grafy pro přicházející a odcházející data a graf útoků, které se uskutečnily v posledním časovém intervalu.


Connections

Spojení

Okno Aktivní síťové spojení zobrazuje všechny přicházející a odcházející spojení, které jsou nebo byly uskutečněné na Vašem systému. Pokud se chcete dozvědět o individuálním spojení víc, klikněte na zvolené spojení nebo stiskněte tlačítko 'Detaily'. Pokud chcete ukončit proces, který vytvořil spojení, stiskněte tlačítko 'Ukončit'. Na zjištění cesty směrem ke vzdálené adrese, zvolte tlačítko 'Trace route'. Pokud si přejete vyhledat adresu na WHOIS databázi, zvolte tlačítko 'WhoIs Lookup'.


Advanced

Rozšířené

Okno rozšířené pravidla firewallu zobrazuje všechny pravidla, které jsou aktivní ve Vašem systému. Rozšířené pravidla mají vyšší prioritu než pravidla aplikací. Pokud chcete přidat nové pravidlo, zvolte tlačítko 'Přidat pravidlo'. Editovat pravidlo je možné pomocí tlačítka 'Editovat pravidlo'. Jestliže chcete pravidlo odstranit, stiskněte tlačítko 'Odstranit'.

Dialog rozšířených pravidel Vám umožňuje specifikovat rozšířená pravidla pro firewall. Tyto pravidla mají vyšší prioritu než pravidla aplikací. Pole 'Popis' může obsahovat jakýkoli text na identifikaci pravidla. 'Protokol' představuje typ protokolu, který bude použitý na komunikaci mezi dvěmi počítači, zvolte protokol 'Jakýkoli', aby se pravidlo vztahovalo na všechny protokoly. 'Směr' může být přicházející nebo odcházející, zvolte 'Jakýkoli' aby se pravidlo vztahovalo na všechny směry. Pole 'Proces' může být prázdné pokud chcete, aby se vztahovalo na všechny aplikace nebo zvolte tlačítko '...' na omezení pravidla pro specifické aplikace. Na omezení pravidla na specifický časový interval nebo specifického uživatele, použijte záznamy 'Uživatel' nebo 'Časové omezení'. 'Lokální počítač' je IP adresa Vašeho počítače. Váš počítač může mít více než jednu síťovou kartu. Zvolte možnost 'Všechny adresy', aby se pravidlo
vztahovalo na všechny Vaše síťové zařízení nebo můžete specifikovat individuální síťovou kartu/adresu zadáním MAC adresy nebo IP adresy. Při zadávání IP adresy máte možnost specifikovat 'Port' nebo možnost ze seznamu 'Maska'. 'Vzdálený počítač' představuje IP nebo MAC adresu vzdáleného počítače. Adresa 0.0.0.0 s maskou 'Jakýkoli' znamená všechny IP adresy.


Options

Nastavení

Okno Nastavení obsahuje všechny nastavení FortKnox Personal Firewall. Záložka 'Hlavní' umožňuje běžné nastavení firewallu. Pokud je volba 'Vypnout sdílení souborů a tiskáren' aktivní, veškeré přístupy k Vašim souborům a tiskárnám je zablokován. Aktivní volba 'Vypnout procházení počítačů v síti' zamezí procházení sdílenými zdrojů počítačů v síti. Tlačítko 'Nastavit heslo' Vám umožňuje chránit nastavení firewallu před změnou pomocí nastavení přístupového hesla. Pokud si přejete zobrazovat bezpečnostní zprávy/zprávy o blokovaných aplikacích, zaškrtněte volbu 'Zobrazit bezpečnostní zprávy/zprávy o blokovaných aplikací v systémové liště'. Jestliže nechcete spustit firewall po startu systému, vypněte volbu 'Automaticky spustit firewall po startu Windows'. Pokud chcete změnit jazyk a skon podle Vašich individuálních preferencí, nastavte seznamy 'Aktivní jazyk' a 'Aktivní skin'. Pokud chcete aplikovat všechny změny v záložce 'Hlavní', stiskněte tlačítko 'Použít'. Záložka 'Rozšířené' umožňuje nastavit rozšířená pravidla firewallu. Intrusion Prevention Systém (IPS) je integrovaný Intrusion Detection Systém (IDS), který zjišťuje známé hrozby v paketovém toku a aktivně
na ně reaguje. Pokud je hrozba zjištěna na základě signatury, uživatel je automaticky upozorněn a dle nastavení, hrozba je zablokována. Volba 'Povolit ochranu NETBIOS' automaticky blokuje veškerou NETBIOS komunikaci z počítačů, které se nacházejí mimo rozsah Vaší lokální podsítě. Volba 'Blokovat UPnP přenos' blokuje UPnP přenos dat, který je často využívaný na útoky na distribuované ochromení služeb(DoS). Pokud některé Vaše aplikace vyžadují UPnP protokol, měli byste tuto volbu vypnout. Volba 'Povolit maskování signatury OS' blokuje běžné metody útočníků na zjištění Vašeho operačního systému. Volba 'Povolit anti-MAC spoofing' blokuje všechen neočekávaný ARP přenos, který nebyl vyžádán Vaším systémem. MAC spoofing je způsob, jak se napojit na komunikační spojení mezi dvěma počítači s cílem získat přístup k jednomu z počítačů. Volba 'Povolit anti-DNS spoofing' blokuje všechny neočekávané DNS odpovědi na Váš systém s cílem předejít DNS útokům. Volba 'Povolit anti-IP spoofing' vytváří náhodné sekvenční čísla pro každý komunikační paket, aby se předešlo napadnutí komunikačního spojení pomocí IP spoofing útoku. Volba
'Povolit identifikaci podle otisku' ověřuje každou aplikaci na změny v souboru. Pokud chcete resetovat všechny otisky pro všechny aplikace použijte tlačítko 'Resetovat'. S aktivní volbou 'Automaticky blokovat útočníka na:', všechny útoky na Váš systém budou automaticky blokované po specifikovanou dobu. Volba 'Blokovat fragmentované pakety' blokuje všechny fragmentované IP pakety. Volba 'Povolit detekci portscan' monitoruje, upozorňuje a blokuje skenování Vašich portů, což je běžný postup útočníků na určení, zda-li máte některé porty otevřené a vhodné pro útok. Volba 'Povolit detekci DoS' kontroluje všechen přenos na Denial of Service (DoS) útoky, které přetěžují systémové služby a blokují využití služeb jejich běžnými uživateli. Volba 'Povolit lokální síťový přenos' povoluje přenos na lokální síti. Volba 'Povolit časovou synchronizaci' povoluje přenos pro komunikaci s integrovaným serverem časové synchronizace. Volba 'Povolit DHCP' povoluje přenos Dynamic Host Configuration Protokolu, který bývá využíván pro automatické přiřazování IP adres a jiných informací pro konfiguraci TCP/IP. Pokud vypnete tuto volbu a potřebujete DHCP pro správné fungování Vašeho systému, musíte vytvořit rozšířené pravidlo pro UDP pakety na vzdálených portech 67 a 68. Volba 'Povolit DNS' povoluje překlad názvů domén na IP adresy. Pokud tuto volbu vypnete, musíte vytvořit rozšířené pravidlo, které povolí UDP přenos na vzdálený port 53. Pokud chcete aplikovat všechny změny v záložce 'Rozšířené', tiskněte tlačítko 'Použít'. Záložka 'Záznamy' umožňuje nastavit vlastnosti záznamů a e-mailové notifikace. Volba 'Povolit bezpečnostní záznamy' umožňuje záznam důležitých a bezpečnostních událostí. Volba 'Povolit systémové záznamy' povoluje záznam událostí souvisejících s funkčností firewallu. Volba 'Povolit záznamy přenosů' povoluje záznam všech přicházejících a odcházejících přenosů. Volba 'Povolit záznamy paketů' povoluje záznam všech komunikačních paketů včetně jejich dat. Na omezení velikosti záznamů přenosů a paketů je možno použít volby 'Maximální velikost záznamu přenosů' a 'Maximální velikost záznamů paketů'. Volba 'Smazat staré záznamy po' nastavuje počet dní, po kterých budou staré záznamy smazány. Nastavením této hodnoty na nulu se toto nastavení vypne. Volba 'Povolit notifikace' zapne notifikaci bezpečnostních událostí e-mailem. Na otestování Vašich e-mailových nastavení zvolte tlačítko 'Otestovat e-mail'. Pokud chcete aplikovat všechny změny v záložce 'Záznamy', stiskněte tlačítko 'Použít'. Záložka 'Různé' umožňuje nastavení ICMP a aktualizací databáze. V této záložce můžete nastavit nastavení ICMP pro přicházející a odcházející pakety. Měnit tyto nastavení je doporučeno jen zkušenému uživateli. Povolená volba 'Upozorňovat na novou verzi' Vám automaticky oznámí, když bude k dispozici nová verze FortKnox Personal Firewallu. Pokud je volba 'Automatická aktualizace signatur' zapnutá, nové signatury budou automaticky stáhnuty a nainstalovány ze serveru. Jestliže chcete signatury aktualizovat manuálně, stiskněte tlačítko 'Aktualizovat'. Pokud chcete aplikovat všechny změny v záložce 'Různé', stiskněte tlačítko 'Použít'.


Applications

Aplikace

Okno Individuální pravidla aplikací zobrazuje všechny pravidla specifické pro individuální aplikace. Každé pravidlo může mít asociovanou akci povolit, zakázat a ptát se a je tu zobrazena každá aplikace, kterou jste potvrdili. Pokud chcete označit všechny položky v seznamu, stiskněte tlačítko 'Označit vše'. Pokud chcete odznačit všechny položky v seznamu, stiskněte tlačítko 'Odznačit vše'. Jestliže chcete změnit akci pro zvolené pravidlo, použijte tlačítka 'Povolit', 'Zakázat' nebo 'Ptát se'. Pravidla s akcí nastavenou na povolit permanentně povolují aplikaci přístup na síť. Pravidla s akcí nastavenou na zakázat jsou permanentně zakázané přistupovat na síť. Pro pravidla, které mají akci nastavenou na ptát se, bude firewall zobrazovat potvrzovací dialog. Tlačítko 'Smazat' smaže pravidlo ze seznamu.


Traffic Log

Záznamy

Okno Záznamy zobrazuje všechny přicházející a odcházející přenosy, které byly realizované za specifikované časové období. Pokud chcete zobrazit záznam z jiného dne, zvolte kalendář v pravé horní části okna. K dispozici jsou čtyři různé druhy záznamů, které je možno zobrazit. Systémový záznam zobrazuje systémovou aktivitu firewallu. Bezpečnostní záznam zobrazuje důležitou aktivitu a aktivitu útoků. Záznam přenosů zobrazuje všechny přicházející a odcházející spojení uskutečněné aplikacemi. Záznam paketů zobrazuje přenosy na paketové úrovni. Pokud se chcete dozvědět víc o individuální záznamové položce, stiskněte tlačítko 'Detaily'. Pokud chcete vymazat aktivní nebo všechny záznamy, stiskněte tlačítko 'Smazat'. Na zjištění cesty směrem ke vzdálené adrese, zvolte tlačítko 'Trace route'. Pokud si přejete vyhledat adresu ve WHOIS databázi, zvolte tlačítko 'WhoIs Lookup'. Jestliže chcete exportovat přenosy do souboru, zvolte tlačítko 'Export...'.


Buy

Koupit

Okno Koupit zobrazuje informace o programu FortKnox Personal Firewall a možnosti jeho nákupu.


Support

Pomoc

Okno Pomoc umožňuje kontaktovat technickou pomoc v případě, že potřebujete pomoci s programem FortKnox Personal Firewall.


Statistics

Statistiken

Fenster 'Historie der Netzübertragungen und Angriffen stellt die Diagramme für ankommende und abgehende Daten und Diagram der Angriffen vor, die im letzten Zeitinterval realisiert sind.


Connections

Verbindungen

Fenster Aktive Netzverbindungen zeigt alle ankommende und abgehende Verbindungen, die in ihrem System sind oder realisiert wurden. Falls sie über der individuellen Verbindung mehr wissen möchten, klicken Sie auf die gewählte Verbindung oder klicken Sie auf die Taste 'Details'. Falls Sie den Prozess, der die Verbindung geschaft hat, beenden möchten, klicken Sie auf die Taste 'Beenden'. Um den Weg Richtung zu der Fernadresse zu finden, wählen Sie Taste 'Trace route'. Falls Sie die Adresse in WHOIS Datenbasis aussuchen möchten, wählen Sie Taste 'WhoIs Lookup'.


Advanced

Erweitert

Fenster 'Erweiterte Regeln' zeigt alle Regeln, die in Ihrem System aktiv sind. Erweiterte Regeln haben höhere Priorität als die Regeln der Aplikationen. Falls Sie eine neue Regel hinzufügen möchten, wählen Sie Taste 'Regel hinzufügen'. Die Regel kann man mit der Taste 'Regel editieren' editieren. Falls Sie die Regel entfernen möchten, wählen Sie Taste 'Entfernen'.

Dialog der erweiterten Regeln ermöglicht Ihnen die erweiterte Regeln für firewall spezifieren. Diese Regeln haben grössere Priorität als die Aplikationsregeln. Feld 'Beschreibung' kann beliebiger Text für die Identifikation der Regel enthalten. 'Protokoll' stellt ein Protokollstyp vor, das für die Komunikation zwischen zwei Comuter angewendet wird, wählen Sie Protokoll 'Jeder', damit sich die Regel auf alle Protokolle beziehen kann. 'Richtung' kann kommende oder abgehende sein, um die Regel auf alle Richtungen zu beziehen, wählen Sie 'Jeder'. Feld 'Prozess' kann leer sein, damit sich die Regel auf alle Aplikationen beziehen kann, oder wählen sie Taste '...' um die Regel nur für spezifische Aplikationen zu beschränken. Um die Regel für spezifisches Zeitintervall oder spezifischen Benützer zu beschränken, verwenden Sie die Liste 'Benutzer' oder 'Zeitbeschränkung'. 'LokalComputer' ist die IP Adresse von Ihrem Computer. Ihr Computer kann mehr als eine Netzkarte haben. Wählen Sie Möglichkeit 'Alle Adressen', damit sich die Regel auf alle Ihre Netzanlagen beziehen wird oder Sie können MAC Adresse oder IP Adresse eingeben und damit die individuelle Netzkarte/Adresse spezifizieren.Während der Eingabe der IP Adresse haben Sie die Möglichkeit 'Port' oder 'Maske' aus der Liste zu spezifizieren. 'FernComputer' stellt IP oder MAC Adresse des entfernten Computers. Adresse 0.0.0.0 mit der Maske 'FernComputer' bedeutet alle IP Adressen.


Options

Einstellungen

Fenster Einstellungen enthält alle FortKnox Personal Firewall Einstellungen. Merkzeichen 'Haupt' ermöglicht die normale firewal Einstellung einzustellen. Falls die Wahl 'Daten- und DruckersMitteilung ausschalten' aktiv ist, alle Zugänge zu Ihren Datein und Druckers ist blockiert. Aktive Wahl 'Durchgang der Computers im Netz ausschalten'verhindert den Durchgang mittgeteilten Quellen der Computer im Netz. Taste 'Passwort' ermöglicht Ihnen die firewall Einstellungen gegen der Änderung mittels des Zutrittspassworteinstellung schutzen. Falls Sie die Sicherheitsnachrichten/Nachrichten über den blockierten Aplikationen abbilden möchten, markieren Sie die Wahl 'Sicherheitsnachrichten/Nachrichten über den blockierten Aplikationen in der Systemleiste'. Falls Sie das firewall nach dem Windowsstart nicht anlassen möchten, schalten Sie die Wahl 'Nach dem Windowsstart das firewall automatisch anlassen' aus. Falls Sie die Sprache und Skins nach Ihren individuellen Preferenzen ändern möchten, stellen Sie 'Aktive Sprache' und 'Aktives Skin' ein. Falls Sie alle Änderungen im Merkzeichen 'Haupt' applizieren möchten, klicken Sie auf die Taste 'Anwenden'. Merkzeichen 'Erweitert' ermöglicht erweiterte Regeln von firewall einzustellen. Intrusion Prevention System (IPS) ist integriertes Intrusion Detection System (IDS), welches die bekannte Drohungen im Paketsverlauf feststellt und auf die Drohungen aktiv reagiert. Wenn die Drohung aufgrund der Signatur festgestellt ist, wird der Benutzer automatisch gewarnt und einstellungsgemäss wird die Drohung blockiert. Die Wahl 'NETBIOS Schutz bewilligen' blockiert automatisch ganze NETBIOS Komunikation von Computers, die sich ausserhalb Ihres Lokalunternetz befinden. Wahl 'UPnP Übertragung blockieren' blockiert UPnP Datenübertragung, die oft zum Attacken auf distribuierte Lähmung der Diensten(DoS) dient. Falls manche Ihre Aplikationen das UPnP Protokoll benötigen, sollten Sie diese Wahl ausschalten. Wahl 'OS Signaturmaskierung bewilligen' blockiert gewöhnliche Attacksmethoden um Ihres Operationssystem festzustellen. Wahl 'Anti-MAC spoofing bewilligen' blockiert ganze unerwartete ARP Übertragung, die nicht von Ihrem System ausgebetet wurde. Mit der Hilfe von MAC spoofing kann man sich auf die Komunikationsverbindung zwischen zwei Computern anschliessen, um den Zugang zu einem davon zu erreichen. Wahl 'Anti-DNS spoofing bewilligen' blockiert alle unerwartete DNS Antworten auf Ihr System, um DNS Attacken vorzubeugen. Wahl 'Anti-IP spoofing bewilligen' schafft zufällige Sekvenznummern für jedes Komunikationspaket, um den Komunikationsverbindungsattack mittels IP spoofing Attacks vorzubeugen. Wahl 'Identifikations dem Abdruck nach bewilligen' prüft jede Aplikation für die Änderung in ihr Datendatei. Falls Sie alle Abdrücke für alle Aplikationen entfernen möchten, wählen Sie die Taste 'Reset'. Mit der aktiv Wahl 'Den Angreifer automatisch blockieren auf:', werden alle Attacken auf Ihr System für spezifische Zeit automatisch blockiert. Wahl 'Fragmentspakets blockieren' blockiert alle FragmentsIPpakets. Wahl 'PortscanDetektion bewilligen' monitoriert, hinweist und blockiert Scannierung von Ihren Ports, was das übliche Methode der Angreifers ist, festzustellen, ob Sie manche Ports offen haben und für den Attaack geeignet sind. Wahl 'DoS Detection bewilligen' kontrolliert ganze Übertragung auf Denial of Service (DoS) Attacken, die die Systemdienste überlasten und die Ausnutzung der Diensten von üblichen Benützer blockieren. Wahl 'Lokal Netzübertragung bewilligen' bewilligt Übertragung im Lokalnetz. Wahl 'Zeitsynchonisation bewilligen' bewilligt die Übertragung für die Komunikation mit dem InternetServer der Zeitsynchronisation. Wahl 'DHCP bewilligen' bewilligt die Übertragung von Dynamic Host Configuration des Protokolls, welches für die automatische Anordnug der IPAdressen und anderer TCP/IP Konfigurationsinfos sorgt. Wenn Sie diese Wahl ausschalten und Sie brauchen DHCP für den richtigen SystemAblauf , müssen Sie erweiterte Regel für UDP Pakets auf den fern Ports 67 und 68 schaffen. Wahl 'DNS bewilligen' bewilligt die Übersetzung der Domännamen auf die IP Adressen. Falls Sie diese Wahl ausschalten, müssen Sie erweiterte Regel schaffen, welche die Übertragung auf fern Port 53 bewilligt. Falls Sie alle Änderungen im Merkzeichen 'Erweitert' applizieren möchten, klicken Sie auf die Taste 'Anwenden'. Merkzeichen 'Datensätze' ermöglicht die Datensätzeeigenschaften und E-mail Notifikation einzustellen. Wahl 'Sicherheitsdatensätze bewilligen' ermöglicht die wichtigen Sicherheitsereignissen einzutragen. Wahl 'Systemdatensätze bewilligen' bewilligt die Notierung der Ereignissen, die mit der Firewallfunktionsfähigkeit zusammenhängen. Wahl 'Ubertragunsdatensätze bewilligen' bewilligt die Notiereung allen ankommenden und abgehenden Übertragungen. Wahl 'Paketsdatensätze bewilligen' bewilligt die Notierung von allen Komunikationspakets mit Daten. Um die Datengrösse der Übertragungen und Pakets zu beschränken, kann man die Wahl 'Maximallgrösse der Übertragungsprotokollierung' und 'Maximallgrösse der Datensätzen.' Wahl'Alte Datensätze löschen nach' stellt die Zahl der Tagen ein, nach der die alten Datensätze gelöscht werden. Einstellung auf Null schaltet diese Einstellung aus. Wahl 'Notifikationen bewilligen' schaltet die Notifikation der Sicherheitsvorfällen mit e-mail. Um Ihre E-maileinstellungen zu testen, wählen Sie die Taste'E-mail testen'. Falls Sie alle Änderungen im Merkzeichen 'Datensätze' aplizieren möchten, klicken Sie auf die Taste 'Anwenden'. Merkzeichen 'Verschieden' ermöglicht ICMP Einstellung und Aktualisierung der Datenbasis. In diesem Merkzeichen können Sie die ICMP Einstellungen für ankommende und abgehende Pakets einstellen. Änderung dieser Einstellungen ist nur dem erfahrenen Benutzer empfohlen. Die erlaubte Wahl 'Auf die neue Version hinweisen' wird Sie automatisch benachrichtigen, wenn die neue FortKnox Personal Firewall Version zur Verfügung stehen wird. Wenn die Wahl 'Automatische Aktualisierung der Signaturen' an ist, neue Signaturen werden automatisch aus dem Server heruntergeladet und instaliert. Falls Sie die Signaturen manuell aktualisieren möchten, klicken Sie auf die Taste 'Aktualisieren'. Falls Sie alle Änderungen im Merkzeichen 'Verschieden' applizieren möchten, klicken Sie auf die Taste 'Anwenden'.


Applications

Aplikationen

Fenster 'Individuelle Aplikationsregeln' zeigt alle Regeln, die spezifisch für individuelle Applikation sind. Jede Regel kann assoziiert haben, die Aktion bewilligen, verbieten und fragen, und hier wird jede Aplikation, die Sie bestätigt haben, abgebildet. Wenn Sie alle Punkte in der Liste markieren möchten, klicken Sie auf die Taste 'Alles markieren'. Wenn Sie alle Punkte in der Liste unmarkieren möchten, klicken Sie auf die Taste 'Alles unmarkieren'. Wenn Sie die Aktion für gewählte Regel ändern möchten, benutzen Sie die Tasten 'Bewilligen', 'Verbieten' oder 'Fragen'. Regeln, mit der auf bewilligen eingestellten Aktion, bewilligen permanent die Aplikation Zugang zum Internet. Regeln, mit der auf verbieten eingestellten Aktion, verbieten permanent den Zugang zum Netz. Für die Regeln, die die Aktion auf fragen eingestellt haben, wird firewall Bestätigungsdialog zeigen. Taste 'Löschen' wird die Regel aus der Liste löschen.


Traffic Log

Datensätze

Fenster 'Datensätze' abbildt alle ankommende und abgehende Übertragungen, die in dem spezifischen Zeitraum realisiert wurden. Wenn Sie der Datensatz aus dem anderen Tag abbilden möchten, wählen Sie Kalender im rechten Teil des Fenster. Zur Verfügung stehen Ihnen vier verschiedene Arten von Datensätzen, die man abbilden kann. System Datensatz abbildt Systemfirewallaktivität. Sicherheitsdatensatz abbildt wichtige Aktivität und Attackenaktivität. Übertragungsdatensatz abbildt alle ankommende und abgehende Verbindungen, die von Aplikationen realisier werden. Paketsdatensatz abbildt Übertragungen auf der Paketsebene. Wenn Sie mehr über den individuellen Datensatzpunkt wissen möchten, klicken Sie auf die Taste 'Details'. Wenn Sie aktive oder alle Datensätze löschen möchten, klicken Sie auf die Taste 'Löschen'. Um den Weg in der Richtung FernAdresse festzustellen, wählen Sie Taste 'Trace route'. Wenn Sie die Adresse in der WHOIS Datenbasis aussuchen möchten, wählen Sie Taste 'WhoIs Lookup'. Wenn Sie die Übertragungen in der Datendatei exportieren möchten, wählen Sie Taste 'Export...'.


Buy

Kaufen

Fenster Kaufen abbildt die Infos über das Programm FortKnox Personal Firewall und über den Einkaufsmöglichkeiten.


Support

Hilfe

Fenster Hilfe ermöglicht die technische Hilfe kontaktieren, falls Sie die Hilfe mit dem Programm FortKnox Personal Firewall brauchen.


Statistics

Statisztika

A hálózati forgalom és támadási előzményekben megtekintheti grafikus formában a bejövő és kimenő adatforgalmat és a támadások gyakoriságát.


Connections

Kapcsolatok

Az aktív hálózati kapcsolatok ablakban az összes bejövő és kimenő kapcsolat megtekinthető a rendszerében. A kapcsolatok egyedi információit megkaphatja ha rákattint egyre, vagy lenyomja a 'Részletek' gombot. Egy kapcsolati folyamt megszakításához, nyomja le a 'Megszakítás' gombot. Az útvonal és a távoli cím megállapításához válassza a 'Követés' gombot. Címek kereséséhez a WHOIS adatbázisban, válassza a 'WhoIs keresés' gombot.


Advanced

Speciális

A speciális tűzfal szabályok ablakban, az összes aktív speciális szabályt tekintheti meg. A speciális szabályok, magasabb prioritásúak mint a program szabályok. Egy újabb hozzáadásához nyomja le a 'Hozzáad' gombot. A szabályok szerkeszthetők a 'Szerkeszt' gomb lenyomásával. Egy szabály eltávolítható a 'Törlés' gomb lenyomásával.

A speciális szabályok ablakban, kibővítheti a tűzfal szabályokat. Ezek a szabályok magasabb prioritással rendelkeznek, mint a program szabályok. A 'Leírás' mezőben bármilyen szöveget beírhat a szabály azonosításához. A 'Protokoll' részben megadhatja, hogy két gép melyik protokollt használja a kommunikációhoz. A 'Bármelyik' lehetőséggel az összes megfelelő protokoll használható. Az 'Útirány' lehet bejövő vagy kimenő, 'Bármelyik' esetén mindkettő irány megegyezik. A 'Folyamat' mező lehet üres minden egyező alkalmazáshoz, vagy használja a '...' gombot egy adott alkalmazás beállításához. A szabály korlátozásához megadhat egy időintervallumot a felhasználó részére az 'Ideiglenes korlátozás' lehetőséggel. A 'Lokális gép' a számítógép IP címét tartalmazza. Ha a gépe egynél több hálózati kártyával rendelkezik, használja az 'Összes cím' lehetőséget valamennyi hálózati csatolójához, vagy adja meg az egyedileg a hálózati kártyák címét a MAC, vagy IP címek beírásával. Amikor megad egy IP címet, adja meg a 'Portot' és az 'Alhálózati maszkot'. A 'Távoli gép' lehetőségnél a távoli számítógép IP, vagy MAC címét adhatja meg. A 0.0.0.0 cím maszk esetén bármelyik IP cím alkalmazásra kerülhet.


Options

Beállítások

A beállítások ablak tartalmazza a FortKnox Personal Firewall beállítási lehetőségeit. Az 'Általános' fülön lehetősége van a közös tűzfal beállításokat elvégezni. Amikor a 'Fájl és nyomtató megosztás tiltása' opció aktív, az összes fájl és nyomtató hozzáférés blokkolva lesz. A 'Hálózatok böngészésének tiltása' opció beállítása esetén a hálózatban lévő gépeken található megosztott állományok nem lesznek elérhetők. A 'Jelszó' gombbal megvédheti a tűzfal beállításait, az illetéktelen módosítások ellen. Biztonsági és blokkolási értesítéseket jeleníthet meg a tálca feletti területen, ha a megfelelő lehetőségeket engedélyezi. A tűzfal nem fog automatikusan elindulni a rendszer indításakor, ha a 'Tűzfal automatikus indítása a Windows-al' lehetőség nincs kiválasztva. Az Önnek megfelelő módon változtathatja meg a felületet és a program nyelvét a listákból történő kiválasztással. A fülön történt összes módosítás engedélyezéséhez, nyomja le az 'Alkalmaz' gombot. A 'Kiegészítések' fülön végezheti el a tűzfal további beállításait. Az integrált behatolás elleni védelem (IPS) és a behatolás észlelő rendszer (IDS) felismeri az ismert fenyegetéseket az adatfolyamatokban és képes aktívan reagálni ezekre. Amikor fenyegetés észlelése történik, a felhasználó automatikusan értesítést kap erről és az alapértelmezett beállításnak megfelelően a fenyegetés blokkolásra kerül. A 'NETBIOS védelem' lehetőséggel automatikusan blokkolásra kerül az összes NETBIOS kommunikáció a gép és az alhálózatok között. Az 'UPnP forgalom blokkolása' lehetőséggel blokkolhatja az UPnP forgalmat, amelyet gyakran a túlterheléses támadások is alkalmaznak. Csak akkor hatástalanítsa a lehetőséget, ha valamely alkalmazása az UPnP protokoll használatát igényli. Az 'OS ujjlenyomat címálcázás' lehetőséggel blokkolhatja a közönséges támadási kísérleteket, amelyek az operációs rendszer észlelésén alapulnak. A 'MAC becsapás elleni védelem' blokkolja az összes váratlan ARP forgalmat, amelyet nem a rendszere igényelt. A MAC becsapás egy hijacker kommunikációs folyamat a számítógépek között. A 'DNS becsapás elleni védelem' lehetőséggel blokkolhatja az összes váratlan DNS reagálást és így megvédheti a rendszerét a DNS támadások ellen. Az 'IP becsapás elleni védelem' lehetőséggel kivédheti a véletlen számgeneráción alapuló hijacker kommunikációs folyamatokat, amelyek az IP becsapás módszerét használják a támadásokhoz. Az 'Ujjlenyomat hitelesítés' lehetőséggel, minden fájlművelet ellenőrzésre kerül. Az összes ellenőrzés visszavonásához használja a 'Visszaállítás' gombot. A 'Támadó automatikus blokkolása:' opcióval engedélyezheti, hogy az összes rendszerét ért támadás blokkolva legyen a megadott intervallumig. A 'Töredék adatcsomagok blokkolása' lehetőséggel elveti az összes szétdarabolt IP adatcsomag fogadását. A 'Portscan észlelés' lehetőséggel blokkolásra kerül a portjainak vizsgálatára irányuló kísérlet, melyet a hackerek használnak nyitott portok keresésére. A 'DoS észlelés' opcióval ellenőrizheti az összes ismert túlterheléses támadást (DoS), amelyek túlterhelik a rendszerét és megbénítják a normál kommunikációt. A 'Helyi hálózat engedélyezése' opcióval az összes helyi hálózati forgalmat engedélyezheti. Az 'Időszinronizáció' opcióval az idő szinkronizálását engedélyezheti egy internetes kiszolgálón keresztül. A 'DHCP engedélyezése' opcióval engedélyezheti a DHCP protokoll forgalmat, amikor IP cím hozzárendelésre és más TCP/IP konfigurációs információkra van szükség. Ha letiltja ezt a lehetőséget, akkor létrehozhat speciális szabályokat az UDP adatcsomagokhoz a 67 és 68-as távoli portokon keresztül. A 'DNS engedélyezése' opcióval engedélyezheti az összes névfeloldást az IP címekhez. Ha letiltja az opciót, manuálisan is létrehozhat speciális szabályokat az UDP forgalomhoz a távoli 53-as porton keresztül. A fülön történt minden módosítás érvényesítéséhez nyomja le az 'Alkalmaz' gombot. A 'Naplózás' fülön a naplózás és a levélbeni értesítés beállításait végezheti el. A 'Biztonsági naplózás' engedélyezésével naplózhatja a fontos biztonsági eseményeket. A 'Rendszer naplózás' lehetőséggel a tűzfal működési eseményeit mentheti el. A 'Forgalom naplózás' lehetőséggel az összes bejövő és kimenő hálózati forgalmat követheti nyomon. A 'Csomag naplózás' beállításával az összes adatforgalom naplózásra kerül. Korlátozhatja a forgalom és csomagnaplók méretét a megfelelő beállítások alkalmazásával. A 'Régiek törlése (nap múlva)' lehetőséggel a beállított érték elérése esetén a régi naplófájlok törlődnek. Ha a beállított érték nulla az opció kikapcsolva. Az 'Értesítések engedélyezése' bekapcsolásával levélben kaphat értesítést biztonsági eseményekről. A saját levelezési beállítása ellenőrzéséhez használja az 'E-mail teszt' gombot. A 'Naplózás' fülön lévő beállítások engedélyezéséhez nyomja le az 'Alkalmaz' gombot. A 'Vegyes' fülön lehetősége van az ICMP és a frissítési beállítások elvégzésére. Ennél a fülnél az ICMP beállításokat végezheti el a bejövő és kimenő adatcsomagokhoz. A beállítások módosítása csak szakértők részére ajánlott. Itt állíthatja be, hogy értesítést kapjon arról, ha a FortKnox Personal Firewall-nak újabb verziója érhető el. Amikor az 'Aláírások automatikus frissítése' opció engedélyezve van, az új aláírások automatikusan letöltésre és telepítésre kerülnek. Az aláírások frissítését elvégezheti manuálisan is, a 'Frissítés' gomb lenyomásával. A 'Vegyes' fülön lévő összes módosítás engedélyezéséhez, nyomja le az 'Alkalmaz' gombot.


Applications

Programok

Az egyedi program szabályok ablakban kilistázásra kerül az összes programhoz tartozó szabály. Minden programhoz beállíthatja az enged, elutasít vagy rákérdez műveletet amelyet itt a listában végezhet el. A lista összes elemét kijelölheti a 'Mind kijelöl' gomb lenyomásával. Az összes kijelölésének a visszavonásához használja a 'Mind visszavon' gombot. A kijelölt szabály módosításához használja az 'Enged', 'Elutasít' vagy 'Rákérdez' gombot. Az 'Enged' lehetőség beállításával az adott program állandóan hozzáférhet a hálózathoz. Az 'Elutasít' lehetőség beállításával az adott program nem férhet hozzá a hálózathoz. A 'Rákérdez' lehetőség esetén a tűzfal rá fog kérdezni a hozzáférésre. A 'Törlés' gombbal eltávolíthat egy szabályt a listából.


Traffic Log

Forgalmi napló

A forgalom napló ablakban megtekintheti az összes bejövő és kimenő forgalmat egy megadott intervallumon belül. Egy másik nap forgalmának megtekintéséhez az ablak jobb felső sarkában található előugró naptár segíti Önt. Lehetősége van négyféle különböző naplózás elvégzésére. A rendszer napló megmutatja a tűzfal aktivitását. A biztonsági napló a támadásokról vagy ahhoz hasonló jelenségekről tájékoztatja. A forgalom napló megjeleníti az összes bejövő és kimenő kapcsolatát. A csomag napló megmutatja a csomagforgalmazás szintjét. Az egyes napló elemekről többet is megtudhat ha lenyomja a 'Részletek' gombot. Az aktív vagy az összes napló törléséhez nyomja le a 'Törlés' gombot. Ha egy távoli címet akar nyomonkövetni, válassza a 'Követés' gombot. Egy távoli cím kikereséséhez a WHOIS adatbázisból, nyomja le a 'WhoIs keresés' gombot. A forgalmi adatok exportálásához nyomja le az 'Exportálás...' gombot.


Buy

Vásárlás

A vásárlás ablakban a termék megvásárlásával kapcsolatban kaphat információkat.


Support

Támogatás

A támogatás ablakban, lehetősége van arra hogy felvegye a kapcsolatot velünk, ha segítségre van szüksége a programhoz.


License Agreement

FortKnox Personal Firewall 2007 License Agreement

Please read the terms and conditions of this license agreement ("License") before installing FortKnox Personal Firewall ("Software"). By installing and using the Software you accept and agree to the terms of this License. This License constitutes the entire agreement concerning the Software between you and NETGATE Technologies s.r.o., Prievidza, Slovak Republic. If you do not agree with these terms and conditions, immediately uninstall the Software. The term "Software" includes, and these terms and conditions also apply to, any updates, modifications and upgrades to the Software that you may receive.

I. License

This License permits you to use one copy of the Software for a single computer. The enclosed documentation ("Documentation") may not be copied. You agree that you will not sublicense, assign, transfer, distribute, pledge, lease, rent or share your rights under this License except with prior written permission from NETGATE Technologies s.r.o. company. You agree that you will not modify, adapt or translate, or disassemble, decompile, reverse engineer or otherwise attempt to discover the source code of the Software.

II. Rights

You acknowledge and agree that the Software and Documentation ("Licensed Products") are proprietary products of NETGATE Technologies s.r.o. protected under copyright law of Slovak Republic, international copyright law and treaties and disclosed to you by NETGATE Technologies s.r.o. in confidence. You shall take all reasonable steps to safeguard the Licensed Products. NETGATE Technologies s.r.o. owns and retains all copyright, trademark, trade secret and other proprietary rights in and to the Licensed Products. This License conveys to you only a non-exclusive and limited right of use, revocable in accordance with the terms and conditions of this License. Unauthorized reproduction or distribution of this program, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the maximum extent possible under law.

III. Upgrades and support

All registered users may recieve upgrades of the Software database. All registered users have right on technical support by the technical support team.

IV. Ownership

The Software is licensed, not sold, to You for Your use only under the terms of this Agreement, and NETGATE Technologies s.r.o. reserves all rights not expressly granted to You. You own the media, if any, on which the Software is recorded, but NETGATE Technologies s.r.o. retains ownership of all copies of the Software itself.

V. Trial

If you are using the Software on a trial basis, and are authorized to do so, then You shall have a license under this Agreement to use the Software for the number of days indicated in the materials accompany the Software ("Trial Period") from the date You install it, solely for the purpose of evaluating the Software to determine whether to purchase an ongoing license to the Software. At the end of the Trial Period, the Software will stop working. During the Trial Period, the Software is provided to You "as is" and Your use is entirely at Your own risk.

VI. Warranty Disclaimer

The Software is provided to You "As Is" and NETGATE Technologies s.r.o. and its suppliers and licensors expressly disclaim any and all warranties and representations of any kind with regard to any subject matter of this Agreement, including, without limitation, any warranty of non-infringement, title, fitness for a particular purpose, functionality or merchantiliability, whether express, implied or statutory. No oral or written information or advice given by NETGATE Technologies s.r.o., its employees, distributors, dealers, or agents shall increase the scope of the above warranties or create any new warranties.

VII. Limited Warranty

NETGATE Technologies s.r.o. warrants to you that the Software will perform substantially in accordance with the Documentation for 90 day period following your receipt of the Software. To make a warranty claim, you must return the Software to the location where you obtained it along with a copy of your sales receipt within 30 day period. If the Software does not perform substantially in accordance with the Documentation, the entire and exclusive liability of NETGATE Technologies s.r.o. and its distributors, and your exclusive remedy shall be limited to either, NETGATE Technologies s.r.o.'s option, the replacement of the Software or the refund of the license fee you paid for the Software.

VIII. Limitations of Liability

Regardless of whether any remedy set forth herein fails of its essential purpose or otherwise, in no event will NETGATE Technologies s.r.o. or its suppliers be liable to You or to any third party for any lost profits, lost data, interruption of business, or other special, indirect, incidental or consequential damages of any kind arising out of the use or inability to use the Software or any data supplied therewith, even if NETGATE Technologies s.r.o. has been advised of the possibility of such loss or damages and whether or not such loss or damages are foreseeable. In no event shall the liability of NETGATE Technologies s.r.o. exceed the total amount received by NETGATE Technologies s.r.o. from You under this Agreement.

IX. Termination

The Agreement becomes effective when You agree to the terms and conditions of this Agreement by opening, installing, using, accessing or manipulating the Software ("Effective Date"), and this Agreement will terminate immediately upon notice to You if You materially breach any term or condition of this Agreement. You agree upon termination to promptly destroy the Software and all copies thereof.

X. High Risk Activity

You acknowledge and agree that the Software is not intended for use with any high risk or strict liability activity, including, without limitation, air or space travel, technical building or structural design, power plant design or operation, life support or emergency medical operations or uses, and that NETGATE Technologies s.r.o. makes no warranty and shall have no liability arising from any use of the Software in any high risk or strict liability activities.

All questions regarding this license agreement please forward to NETGATE Technologies s.r.o., Tajovskeho 8, 97101 Prievidza, Slovak Republic or by e-mail to netgate@netgate.sk.